GetLightDimmer Method


Gets the dimmer value for the given light for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double GetLightDimmer(
	ElementId viewId,
	ElementId lightId
)
Visual Basic
Public Function GetLightDimmer ( _
	viewId As ElementId, _
	lightId As ElementId _
) As Double
Visual C++
public:
double GetLightDimmer(
	ElementId^ viewId, 
	ElementId^ lightId
)

Parameters

viewId
Type: Autodesk.Revit.DBElementId
The Id of the view
lightId
Type: Autodesk.Revit.DBElementId
The Id of the light to turn on or off

Remarks

The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also