Creates an IFCLevelInfo.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- buildingStorey
- Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The building storey handle (IfcBuildingStorey).
- localPlacement
- Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The local placement handle (IfcLocalPlacement).
- height
- Type: System Double
The height of the level.
- elevation
- Type: System Double
The elevation of the level.
- scaleFactor
- Type: System Double
The scale factor.
- isPrimaryLevel
- Type: System Boolean
True if this is primary level, false otherwise.
Return Value
The IFCLevelInfo object.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |