Create Method


Creates an IFCLevelInfo.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static IFCLevelInfo Create(
	IFCAnyHandle buildingStorey,
	IFCAnyHandle localPlacement,
	double height,
	double elevation,
	double scaleFactor,
	bool isPrimaryLevel
)
Visual Basic
Public Shared Function Create ( _
	buildingStorey As IFCAnyHandle, _
	localPlacement As IFCAnyHandle, _
	height As Double, _
	elevation As Double, _
	scaleFactor As Double, _
	isPrimaryLevel As Boolean _
) As IFCLevelInfo
Visual C++
public:
static IFCLevelInfo^ Create(
	IFCAnyHandle^ buildingStorey, 
	IFCAnyHandle^ localPlacement, 
	double height, 
	double elevation, 
	double scaleFactor, 
	bool isPrimaryLevel
)

Parameters

buildingStorey
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The building storey handle (IfcBuildingStorey).
localPlacement
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The local placement handle (IfcLocalPlacement).
height
Type: SystemDouble
The height of the level.
elevation
Type: SystemDouble
The elevation of the level.
scaleFactor
Type: SystemDouble
The scale factor.
isPrimaryLevel
Type: SystemBoolean
True if this is primary level, false otherwise.

Return Value

The IFCLevelInfo object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also