Create Method


IFCLevel Info Create Method

Creates an IFCLevelInfo.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IFCLevelInfo Create(
	IFCAnyHandle buildingStorey,
	IFCAnyHandle localPlacement,
	double height,
	double elevation,
	double scaleFactor,
	bool isPrimaryLevel
)

Parameters

buildingStorey IFCAnyHandle
The building storey handle (IfcBuildingStorey).
localPlacement IFCAnyHandle
The local placement handle (IfcLocalPlacement).
height Double
The height of the level.
elevation Double
The elevation of the level.
scaleFactor Double
The scale factor.
isPrimaryLevel Boolean
True if this is primary level, false otherwise.

Return Value

IFCLevelInfo
The IFCLevelInfo object.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also