Creates a new instance of a single Fabric wire.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- distance
- Type: System Double
The distance between this wire and the next wire in the Custom Fabric Sheet
- wireLength
- Type: System Double
Length of this wire
- wireType
- Type: Autodesk.Revit.DB ElementId
The wire type of this wire
- wireOffset
- Type: System Double
The offset between two wires in the same line
Return Value
The newly created Fabric wire instance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for distance is not a number -or- The given value for wireLength is not a number -or- wireType is not a valid Element identifier. -or- The given value for wireOffset is not a number |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for distance must be between 0 and 30000 feet. -or- The given value for wireLength must be greater than 0 and no more than 30000 feet. -or- The given value for wireOffset must be between 0 and 30000 feet. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |