Fabric |
Creates a new instance of a single Fabric wire.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static FabricWireItem Create(
double distance,
double wireLength,
ElementId wireType,
double wireOffset
)
Parameters
- distance Double
- The distance between this wire and the next wire in the Custom Fabric Sheet
- wireLength Double
- Length of this wire
- wireType ElementId
- The wire type of this wire
- wireOffset Double
- The offset between two wires in the same line
Return Value
FabricWireItemThe newly created Fabric wire instance.

Exception | Condition |
---|---|
ArgumentException | The given value for distance is not a number -or- The given value for wireLength is not a number -or- wireType is not a valid Element identifier. -or- The given value for wireOffset is not a number |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for distance must be between 0 and 30000 feet. -or- The given value for wireLength must be greater than 0 and no more than 30000 feet. -or- The given value for wireOffset must be between 0 and 30000 feet. |