Create Method (Double, Double, ElementId, Double)


Creates a new instance of a single Fabric wire.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static FabricWireItem Create(
	double distance,
	double wireLength,
	ElementId wireType,
	double wireOffset
)
Visual Basic
Public Shared Function Create ( _
	distance As Double, _
	wireLength As Double, _
	wireType As ElementId, _
	wireOffset As Double _
) As FabricWireItem
Visual C++
public:
static FabricWireItem^ Create(
	double distance, 
	double wireLength, 
	ElementId^ wireType, 
	double wireOffset
)

Parameters

distance
Type: SystemDouble
The distance between this wire and the next wire in the Custom Fabric Sheet
wireLength
Type: SystemDouble
Length of this wire
wireType
Type: Autodesk.Revit.DBElementId
The wire type of this wire
wireOffset
Type: SystemDouble
The offset between two wires in the same line

Return Value

The newly created Fabric wire instance.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given value for distance is not a number -or- The given value for wireLength is not a number -or- wireType is not a valid Element identifier. -or- The given value for wireOffset is not a number
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The given value for distance must be between 0 and 30000 feet. -or- The given value for wireLength must be greater than 0 and no more than 30000 feet. -or- The given value for wireOffset must be between 0 and 30000 feet.

See Also