GetExportLineweightInfo Method


Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ExportLineweightInfo GetExportLineweightInfo(
	ExportLineweightKey exportLineweightKey
)
Visual Basic
Public Function GetExportLineweightInfo ( _
	exportLineweightKey As ExportLineweightKey _
) As ExportLineweightInfo
Visual C++
public:
ExportLineweightInfo^ GetExportLineweightInfo(
	ExportLineweightKey^ exportLineweightKey
)

Parameters

exportLineweightKey
Type: Autodesk.Revit.DBExportLineweightKey
The export line weight Key.

Return Value

Returns the line weight info for this key.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException An entry with the given key is not present in the table.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also