RemoveParameterFromSegment Method


Remove constraints from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveParameterFromSegment(
	int iSegment,
	ElementId paramId
)
Visual Basic
Public Sub RemoveParameterFromSegment ( _
	iSegment As Integer, _
	paramId As ElementId _
)
Visual C++
public:
void RemoveParameterFromSegment(
	int iSegment, 
	ElementId^ paramId
)

Parameters

iSegment
Type: SystemInt32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DBElementId
Id of a parameter driving one or more constraints.

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException iSegment is not between 0 and NumberOfSegments. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Reinforcement_Length or UT_Angle.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also