RemoveParameterFromSegment Method


Rebar Shape Definition By Segments Remove Parameter From Segment Method

Remove constraints from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void RemoveParameterFromSegment(
	int iSegment,
	ElementId paramId
)

Parameters

iSegment Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId ElementId
Id of a parameter driving one or more constraints.
Exceptions
Exception Condition
ArgumentException iSegment is not between 0 and NumberOfSegments. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not Reinforcement_Length, Angle or Number.
ArgumentNullException A non-optional argument was null
Remarks
This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.
See Also