Rebar |
Remove constraints from a segment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | iSegment is not between 0 and NumberOfSegments. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Reinforcement_Length or UT_Angle. |
ArgumentNullException | A non-optional argument was null |

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.