IsADirectContext3DHandleCategory Method


Checks whether the provided category ID is one of the categories used by DirectContext3D handle elements.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static bool IsADirectContext3DHandleCategory(
	ElementId categoryId
)
Visual Basic
Public Shared Function IsADirectContext3DHandleCategory ( _
	categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsADirectContext3DHandleCategory(
	ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DBElementId
The category ID to check.

Return Value

True, if the category is valid for DirectContext3D handle elements, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also