IsValidRebarShapeId Method


Identifies whether an element id corresponds to a Rebar Shape element which can be used in Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidRebarShapeId(
	Document aDoc,
	ElementId elementId
)
Visual Basic
Public Shared Function IsValidRebarShapeId ( _
	aDoc As Document, _
	elementId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidRebarShapeId(
	Document^ aDoc, 
	ElementId^ elementId
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document.
elementId
Type: Autodesk.Revit.DBElementId
An element id.

Return Value

True if the specified element id corresponds to a Rebar Shape element.

Remarks

The Rebar Shape has to be two dimensional shape only and its neighbouring segments may form only right angles.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also