IsValidRebarShapeId Method


Path Reinforcement Is Valid Rebar Shape Id Method

Identifies whether an element id corresponds to a Rebar Shape element which can be used in Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static bool IsValidRebarShapeId(
	Document aDoc,
	ElementId elementId
)

Parameters

aDoc Document
The document.
elementId ElementId
An element id.

Return Value

Boolean
True if the specified element id corresponds to a Rebar Shape element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The Rebar Shape has to be two dimensional shape only and its neighbouring segments may form only right angles. Rebar Shapes that have end treatments or crank ar not allowed.
See Also