Creates a new geometric Curve object from NURBS curve data containing just control points and weights. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- controlPoints
- Type: System.Collections.GenericIListXYZ
The control points of the NURBSpline.
- weights
- Type: System.Collections.GenericIListDouble
The weights of the NURBSpline.
Return Value
The new Curve object.Remarks
There must be at least 2 control points. The number of weights must be equal to the the number of control points. The values of all weights must be positive.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The number of control points must be at least 2. -or- The number of weights must be the same as the number of control points and all weights must be positive. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance). |