GetFileName Method


Gets the file name that will be produced when exporting a view to an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static string GetFileName(
	Document aDoc,
	ElementId dbViewId
)
Visual Basic
Public Shared Function GetFileName ( _
	aDoc As Document, _
	dbViewId As ElementId _
) As String
Visual C++
public:
static String^ GetFileName(
	Document^ aDoc, 
	ElementId^ dbViewId
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
The document that owns the view.
dbViewId
Type: Autodesk.Revit.DBElementId
View which is to be exported as image.

Return Value

The generated exported image file name.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also