GetLabelFor Method (PipeFlowState, Document)


Gets the user-visible name for a PipeFlowState.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static string GetLabelFor(
	PipeFlowState pipeFlowState,
	Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
	pipeFlowState As PipeFlowState, _
	doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
	PipeFlowState pipeFlowState, 
	Document^ doc
)

Parameters

pipeFlowState
Type: Autodesk.Revit.DB.PlumbingPipeFlowState
The PipeFlowState to get the user-visible name.
doc
Type: Autodesk.Revit.DBDocument
The document from which to get the PipeFlowState.

Remarks

The name is obtained in the current Revit language.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when information for the input PipeFlowState cannot be found.

See Also