Constructs a new RebarBendData using the bar type, hook types, style and orientation values.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barType
- Type: Autodesk.Revit.DB.StructureRebarBarType
- hookType0
- Type: Autodesk.Revit.DB.StructureRebarHookType
- hookType1
- Type: Autodesk.Revit.DB.StructureRebarHookType
- style
- Type: Autodesk.Revit.DB.StructureRebarStyle
- hookOrient0
- Type: Autodesk.Revit.DB.StructureRebarHookOrientation
- hookOrient1
- Type: Autodesk.Revit.DB.StructureRebarHookOrientation
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |