RebarBendData Constructor (RebarBarType, RebarHookType, RebarHookType, RebarStyle, RebarHookOrientation, RebarHookOrientation)


Rebar Bend Data(Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, Rebar Style, Rebar Hook Orientation, Rebar Hook Orientation) Constructor

Note: This API is now obsolete.

Constructs a new RebarBendData using the bar type, hook types, style and orientation values.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This constructor is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarBendData(RebarBarType barType, RebarStyle style, BarTerminationsData barTerminationsData);")]
public RebarBendData(
	RebarBarType barType,
	RebarHookType hookType0,
	RebarHookType hookType1,
	RebarStyle style,
	RebarHookOrientation terminationOrientation0,
	RebarHookOrientation terminationOrientation1
)

Parameters

barType RebarBarType
The RebarBarType.
hookType0 RebarHookType
The RebarHookType for the start. Can be .
hookType1 RebarHookType
The RebarHookType for the end. Can be .
style RebarStyle
The style.
terminationOrientation0 RebarHookOrientation
The termination orientation for the start.
terminationOrientation1 RebarHookOrientation
The termination orientation for the end.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also