RebarBendData Constructor (RebarBarType, RebarHookType, RebarHookType, RebarStyle, RebarHookOrientation, RebarHookOrientation)


Rebar Bend Data(Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, Rebar Style, Rebar Hook Orientation, Rebar Hook Orientation) Constructor

Constructs a new RebarBendData using the bar type, hook types, style and orientation values.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarBendData(
	RebarBarType barType,
	RebarHookType hookType0,
	RebarHookType hookType1,
	RebarStyle style,
	RebarHookOrientation hookOrient0,
	RebarHookOrientation hookOrient1
)

Parameters

barType RebarBarType
hookType0 RebarHookType
hookType1 RebarHookType
style RebarStyle
hookOrient0 RebarHookOrientation
hookOrient1 RebarHookOrientation
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also