Rename a family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DBFamilyParameter
The family parameter.
- name
- Type: SystemString
The new name.
Remarks
This operation is valid only for Family Parameters, and is invalid for Shared Parameters and Built-in Parameters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input name string contains illegal characters, or duplicated with existing parameter name. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when trying to rename a built-in parameter or shared parameter. |