Family |
Rename a family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familyParameter FamilyParameter
- The family parameter.
- name String
- The new name.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is . |
ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input name string contains illegal characters, or duplicated with existing parameter name. |
InvalidOperationException | Thrown when trying to rename a built-in parameter or shared parameter. |

This operation is valid only for Family Parameters, and is invalid for Shared Parameters and Built-in Parameters.