Creates a new pipe schedule type with the given name.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The document
- name
- Type: SystemString
The name of requested schedule type.
Return Value
Returns the newly created schedule type.Remarks
If the name is already taken by an existing schedule type, an InvalidOperationException will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | name is an empty string. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.ExceptionsInvalidOperationException | The name is already taken by an existing pipe schedule type. |