Create Method


Pipe Schedule Type Create Method

Creates a new pipe schedule type with the given name.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PipeScheduleType Create(
	Document doc,
	string name
)

Parameters

doc Document
The document
name String
The name of requested schedule type.

Return Value

PipeScheduleType
Returns the newly created schedule type.
Exceptions
Exception Condition
ArgumentException name is an empty string.
ArgumentNullException A non-optional argument was null
InvalidOperationException The name is already taken by an existing pipe schedule type.
Remarks
If the name is already taken by an existing schedule type, an InvalidOperationException will be thrown.
See Also