Pipe |
Creates a new pipe schedule type with the given name.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | name is an empty string. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The name is already taken by an existing pipe schedule type. |

If the name is already taken by an existing schedule type, an InvalidOperationException will be thrown.