Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: SystemInt32
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex
- Type: SystemInt32
An index between 0 and (NumberOfBarPositions-1).
- hookNormal
- Type: Autodesk.Revit.DBXYZ
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Normal hookNormal for end end isn't a valid normal for bar with index barPositionIndex |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. -or- hookNormal has zero length. |
Autodesk.Revit.ExceptionsInvalidOperationException | This RebarFreeFormAccessor Rebar is constrained. |