SetHookPlaneNormalForBarIdx Method


Rebar Free Form Accessor Set Hook Plane Normal For Bar Idx Method

Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. Will throw exception if the rebar has valid constraints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetHookPlaneNormalForBarIdx(
	int end,
	int barPositionIndex,
	XYZ hookNormal
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
An index between 0 and (NumberOfBarPositions-1).
hookNormal XYZ
The normal of plane in which the hook at end of bar with index barPositionIndex will stay. The normal should be perpendicular to the bar direction at the specified end of bar.
Exceptions
Exception Condition
ArgumentException Normal hookNormal for end end isn't a valid normal for bar with index barPositionIndex
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. -or- hookNormal has zero length.
InvalidOperationException This RebarFreeFormAccessor Rebar is constrained.
See Also