SetHookPlaneNormalForBarIdx Method


Rebar Free Form Accessor Set Hook Plane Normal For Bar Idx Method

Note: This API is now obsolete.

Set the plane's normal in which the termination at end of bar with index barPositionIndex will stay. The plane's normal will be used for both hook and crank. Will throw exception if the rebar has valid constraints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarFreeFormAccessor.SetTerminationPlaneNormalForBarIndex instead.")]
public void SetHookPlaneNormalForBarIdx(
	int end,
	int barPositionIndex,
	XYZ terminationPlaneNormal
)

Parameters

end Int32
The end of bar. Should be 0 for start or 1 for end.
barPositionIndex Int32
An index between 0 and (NumberOfBarPositions-1).
terminationPlaneNormal XYZ
The plane's in which the termination at end of bar with index barPositionIndex will stay. The plane's normal will be used for both hook and crank. The normal should be perpendicular to the bar direction at the specified end of bar.
Exceptions
Exception Condition
ArgumentException Normal terminationPlaneNormal for end end isn't a valid normal for bar with index barPositionIndex
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- Invalid end. -or- terminationPlaneNormal has zero length.
InvalidOperationException This RebarFreeFormAccessor Rebar is constrained.
See Also