Returns the positive offset direction vector.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The positive offset direction vector.Remarks
This is available only for constraints of type ToOtherRebar.
Valid TargetRebarConstraintType are:
- RebarPlane
- Edge
- OutOfPlaneExtent
- StartOfBar, only if the RebarShape has a definition of RebarShapeMultiplanarDefinition with [!:RebarShapeMultiplanarDefinition::IsStartConnectorPressent]
- EndOfBar, only if the RebarShape has a definition of RebarShapeMultiplanarDefinition with [!:RebarShapeMultiplanarDefinition::IsEndConnectorPressent]
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The TargetRebarConstraintType is not valid. |