Rebar |
Returns the positive offset direction vector.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- The TargetRebarConstraintType is not valid. |

This is available only for constraints of type ToOtherRebar .
Valid TargetRebarConstraintType are:
- RebarPlane
- Edge
- OutOfPlaneExtent
- StartOfBar , only if the RebarShape has a definition of RebarShapeMultiplanarDefinition with [!:RebarShapeMultiplanarDefinition::IsStartConnectorPressent]
- EndOfBar , only if the RebarShape has a definition of RebarShapeMultiplanarDefinition with [!:RebarShapeMultiplanarDefinition::IsEndConnectorPressent]