GetPositiveOffsetDirectionForToOtherRebarConstraint Method


Rebar Constraint Get Positive Offset Direction For To Other Rebar Constraint Method

Returns the positive offset direction vector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetPositiveOffsetDirectionForToOtherRebarConstraint()

Return Value

XYZ
The positive offset direction vector.
Exceptions
Exception Condition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- The TargetRebarConstraintType is not valid.
Remarks

This is available only for constraints of type ToOtherRebar .

Valid TargetRebarConstraintType are:

See Also