Creates a light type object from the given document and family type ID
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document the typeId is from
- typeId
- Type: Autodesk.Revit.DBElementId
The ID of the light family type
Return Value
The newly created LightType objectExamples

public LightType GetLightTypeFromLightSymbol(Document document)
{
if (document.IsFamilyDocument) // not used in family document
return null;
// In order to get the light infromation, please get a light fixture symbol first
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures);
FamilySymbol lightSymbo = collector.Cast<FamilySymbol>().First<FamilySymbol>();
if (lightSymbo == null) // check null reference
return null;
// Get the LightType for given light fixture sybmol
return LightType.GetLightType(document, lightSymbo.Id);
}

Public Function GetLightTypeFromLightSymbol(document As Document) As LightType
If document.IsFamilyDocument Then
' not used in family document
Return Nothing
End If
' In order to get the light infromation, please get a light fixture symbol first
Dim collector As New FilteredElementCollector(document)
collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures)
Dim lightSymbo As FamilySymbol = collector.Cast(Of FamilySymbol)().First()
If lightSymbo Is Nothing Then
' check null reference
Return Nothing
End If
' Get the LightType for given light fixture sybmol
Return LightType.GetLightType(document, lightSymbo.Id)
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |