GetLightType Method


Light Type Get Light Type Method

Creates a light type object from the given document and family type ID

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static LightType GetLightType(
	Document document,
	ElementId typeId
)

Parameters

document Document
The document the typeId is from
typeId ElementId
The ID of the light family type

Return Value

LightType
The newly created LightType object
Exceptions
Exception Condition
ArgumentException The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element.
ArgumentNullException A non-optional argument was null
Example
public LightType GetLightTypeFromLightSymbol(Document document)
{
    if (document.IsFamilyDocument) // not used in family document
        return null;

    // In order to get the light infromation, please get a light fixture symbol first
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_LightingFixtures);
    FamilySymbol lightSymbo = collector.Cast<FamilySymbol>().First<FamilySymbol>();
    if (lightSymbo == null)    // check null reference
        return null;

    // Get the LightType for given light fixture sybmol
    return LightType.GetLightType(document, lightSymbo.Id);
}
See Also