GetLightType Method


Light Type Get Light Type Method

Creates a light type object from the given document and family type ID

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static LightType GetLightType(
	Document document,
	ElementId typeId
)

Parameters

document Document
The document the typeId is from
typeId ElementId
The ID of the light family type

Return Value

LightType
The newly created LightType object
Exceptions
Exception Condition
ArgumentException The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element.
ArgumentNullException A non-optional argument was null
See Also