SetHookTypeId Method


Set the id of the RebarHookType to be applied to the rebar. If an EndTreatmentType is present at the rebar end, it will automatically set to invalidElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2009

Syntax

C#
public void SetHookTypeId(
	int end,
	ElementId hookTypeId
)
Visual Basic
Public Sub SetHookTypeId ( _
	end As Integer, _
	hookTypeId As ElementId _
)
Visual C++
public:
void SetHookTypeId(
	int end, 
	ElementId^ hookTypeId
)

Parameters

end
Type: SystemInt32
0 for the start hook, 1 for the end hook.
hookTypeId
Type: Autodesk.Revit.DBElementId
The id of a RebarHookType element, or invalidElementId if the rebar should have no hook at the specified end.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException the rebar hook type id hookTypeId is not valid
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException end must be 0 or 1.

See Also