Rebar
Set
|
Set the id of the RebarHookType to be applied to the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

Parameters
- end Int32
- 0 for the start hook, 1 for the end hook.
- hookTypeId ElementId
- The id of a RebarHookType element, or invalidElementId if the rebar should have no hook at the specified end.

Exception | Condition |
---|---|
ArgumentException | the rebar hook type id hookTypeId is not valid |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | end must be 0 or 1. |