SetHookTypeId Method


Rebar Set Hook Type Id Method

Set the id of the RebarHookType to be applied to the rebar. If an EndTreatmentType is present at the rebar end, it will automatically set to invalidElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetHookTypeId(
	int end,
	ElementId hookTypeId
)

Parameters

end Int32
0 for the start hook, 1 for the end hook.
hookTypeId ElementId
The id of a RebarHookType element, or invalidElementId if the rebar should have no hook at the specified end.
Exceptions
Exception Condition
ArgumentException the rebar hook type id hookTypeId is not valid
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
See Also