Get the id of the EndTreatmentType to be applied to the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: SystemInt32
0 for the start end treatment, 1 for the end end treatment.
Return Value
The id of a EndTreatmentType, or invalidElementId if the rebar has no end treatment at the specified end.Examples

private void ListEndTreatments(Document doc, List<Rebar> bars)
{
StringBuilder info = new StringBuilder();
for (int n = 0; n < bars.Count; n++)
{
// get end treatment for both ends of bar
for (int i = 0; i < 2; i++)
{
ElementId treatmentTypeId = bars[n].GetEndTreatmentTypeId(i);
if (treatmentTypeId != ElementId.InvalidElementId)
{
EndTreatmentType treatmentType = doc.GetElement(treatmentTypeId) as EndTreatmentType;
info.AppendLine(string.Format("End treatment for bar {0} end {1}: {2}", n, i, treatmentType.EndTreatment));
}
}
}
TaskDialog.Show("Revit", info.ToString());
}

Private Sub ListEndTreatments(doc As Document, bars As List(Of Rebar))
Dim info As New StringBuilder()
For n As Integer = 0 To bars.Count - 1
' get end treatment for both ends of bar
For i As Integer = 0 To 1
Dim treatmentTypeId As ElementId = bars(n).GetEndTreatmentTypeId(i)
If treatmentTypeId <> ElementId.InvalidElementId Then
Dim treatmentType As EndTreatmentType = TryCast(doc.GetElement(treatmentTypeId), EndTreatmentType)
info.AppendLine(String.Format("End treatment for bar {0} end {1}: {2}", n, i, treatmentType.EndTreatment))
End If
Next
Next
TaskDialog.Show("Revit", info.ToString())
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | end must be 0 or 1. |