GetEndTreatmentTypeId Method


Rebar Get End Treatment Type Id Method

Get the id of the EndTreatmentType to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId GetEndTreatmentTypeId(
	int end
)

Parameters

end Int32
0 for the start end treatment, 1 for the end end treatment.

Return Value

ElementId
The id of a EndTreatmentType, or invalidElementId if the rebar has no end treatment at the specified end.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
See Also