Rebar Get |
Get the id of the EndTreatmentType to be applied to the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- end Int32
- 0 for the start end treatment, 1 for the end end treatment.
Return Value
ElementIdThe id of a EndTreatmentType, or invalidElementId if the rebar has no end treatment at the specified end.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | end must be 0 or 1. |

private void ListEndTreatments(Document doc, List<Rebar> bars)
{
StringBuilder info = new StringBuilder();
for (int n = 0; n < bars.Count; n++)
{
// get end treatment for both ends of bar
for (int i = 0; i < 2; i++)
{
ElementId treatmentTypeId = bars[n].GetEndTreatmentTypeId(i);
if (treatmentTypeId != ElementId.InvalidElementId)
{
EndTreatmentType treatmentType = doc.GetElement(treatmentTypeId) as EndTreatmentType;
info.AppendLine(string.Format("End treatment for bar {0} end {1}: {2}", n, i, treatmentType.EndTreatment));
}
}
}
TaskDialog.Show("Revit", info.ToString());
}