AddProfile Method


Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public int AddProfile(
	Reference edgeReference,
	double param
)
Visual Basic
Public Function AddProfile ( _
	edgeReference As Reference, _
	param As Double _
) As Integer
Visual C++
public:
int AddProfile(
	Reference^ edgeReference, 
	double param
)

Parameters

edgeReference
Type: Autodesk.Revit.DBReference
The geometry reference of edge.
param
Type: SystemDouble
The param on edge to specify the location.

Return Value

Index of newly created profile.

See Also