IsValidEndPoints Method


Identifies if two end points are valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static bool IsValidEndPoints(
	XYZ startPoint,
	XYZ endPoint
)
Visual Basic
Public Shared Function IsValidEndPoints ( _
	startPoint As XYZ, _
	endPoint As XYZ _
) As Boolean
Visual C++
public:
static bool IsValidEndPoints(
	XYZ^ startPoint, 
	XYZ^ endPoint
)

Parameters

startPoint
Type: Autodesk.Revit.DBXYZ
The start point of the location line.
endPoint
Type: Autodesk.Revit.DBXYZ
The end point of the location line.

Return Value

True if the two end points are valid, false otherwise.

Remarks

The two points should not be too close.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also