Analyze As has various functions within the Analytical Model, and is Element-dependent.
"Not for Analysis" usually means that there will not be an Analytical Model generated.
The others indicate how the Analytical Model behavior will treat the Element in question.
For instance "Hanger" columns have different support expectations than "Gravity" columns.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Hanger | A hanging Element. |
Gravity | Interpreted as Gravity (support going down). |
Lateral | Interpreted as Lateral (support going across). |
SlabOneWay | Floor interpreted as Slab One-Way. |
Mat | Floor interpreted as Mat Foundation, or general foundation. |
SlabOnGrade | Floor interpreted as Slab on a Grade. |
NotForAnalysis | Element is not for Analysis. |
NotApplicable | Analyze As is not applicable. |
SlabTwoWay | Floor interpreted as Slab Two-Way. |
GravityLateral | Wall interpreted as Gravity and Lateral |