AnalyzeAs Enumeration


Analyze As Enumeration

Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum AnalyzeAs
Members
Member name Value Description
Hanger 0 A hanging Element.
Gravity 1 Interpreted as Gravity (support going down).
Lateral 2 Interpreted as Lateral (support going across).
SlabOneWay 3 Floor interpreted as Slab One-Way.
Mat 4 Floor interpreted as Mat Foundation, or general foundation.
SlabOnGrade 5 Floor interpreted as Slab on a Grade.
NotForAnalysis 7 Element is not for Analysis.
NotApplicable 8 Analyze As is not applicable.
SlabTwoWay 9 Floor interpreted as Slab Two-Way.
GravityLateral 10 Wall interpreted as Gravity and Lateral
See Also