AnalyzeAs Enumeration


Analyze As Enumeration

Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum AnalyzeAs
Members
Member name Value Description
Gravity 1 Interpreted as Gravity (support going down).
GravityLateral 10 Wall interpreted as Gravity and Lateral
Hanger 0 A hanging Element.
Lateral 2 Interpreted as Lateral (support going across).
Mat 4 Floor interpreted as Mat Foundation, or general foundation.
NotApplicable 8 Analyze As is not applicable.
NotForAnalysis 7 Element is not for Analysis.
SlabOneWay 3 Floor interpreted as Slab One-Way.
SlabOnGrade 5 Floor interpreted as Slab on a Grade.
SlabTwoWay 9 Floor interpreted as Slab Two-Way.
See Also