GetOffsetForIntersectingReference Method


Gets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double GetOffsetForIntersectingReference(
	ElementId intersectingReference
)
Visual Basic
Public Function GetOffsetForIntersectingReference ( _
	intersectingReference As ElementId _
) As Double
Visual C++
public:
double GetOffsetForIntersectingReference(
	ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DBElementId
The intersecting reference to obtain offset value from.

Return Value

The offset for the intersecting reference

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException PartMaker does not use the specified intersecting reference.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also