AddTab Method


Add tab to option dialog with tab name and handler information.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public void AddTab(
	string newTabName,
	TabbedDialogExtension tabbedDialogExtension
)
Visual Basic
Public Sub AddTab ( _
	newTabName As String, _
	tabbedDialogExtension As TabbedDialogExtension _
)
Visual C++
public:
void AddTab(
	String^ newTabName, 
	TabbedDialogExtension^ tabbedDialogExtension
)

Parameters

newTabName
Type: SystemString
The new tab page name.
tabbedDialogExtension
Type: Autodesk.Revit.UITabbedDialogExtension
The handlers information for the new tab page.

Remarks

There is a limit to the number of options page permitted in the dialog.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when the limit of pages allowed in the Options dialog will be exceeded (99).

See Also