AddTab Method


Displaying Options Dialog Event Args Add Tab Method

Add tab to option dialog with tab name and handler information.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddTab(
	string newTabName,
	TabbedDialogExtension tabbedDialogExtension
)

Parameters

newTabName String
The new tab page name.
tabbedDialogExtension TabbedDialogExtension
The handlers information for the new tab page.
Exceptions
Exception Condition
InvalidOperationException Thrown when the limit of pages allowed in the Options dialog will be exceeded (99).
Remarks
There is a limit to the number of options page permitted in the dialog.
See Also