GetLevelAssociationData Method


Returns LevelAssociationData associated with this element, if it exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static LevelAssociationData GetLevelAssociationData(
	Element element
)
Visual Basic
Public Shared Function GetLevelAssociationData ( _
	element As Element _
) As LevelAssociationData
Visual C++
public:
static LevelAssociationData^ GetLevelAssociationData(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DBElement
The element from which we try to obtain LevelAssociationData.

Remarks

If the input element doesn't have LevelAssociationData than it retuns a null reference (Nothing in Visual Basic).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also