CanAddExternallyTaggedNonBRep Method


Checks if the input geometry could be added to this collection or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public bool CanAddExternallyTaggedNonBRep(
	ExternallyTaggedNonBRep geometry
)
Visual Basic
Public Function CanAddExternallyTaggedNonBRep ( _
	geometry As ExternallyTaggedNonBRep _
) As Boolean
Visual C++
public:
bool CanAddExternallyTaggedNonBRep(
	ExternallyTaggedNonBRep^ geometry
)

Return Value

True if we can add the input geometry to this collection, false otherwise.

Remarks

Duplicate ExternalGeometryIds are prohibited.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also